Guide

USER GUIDE

InterfaceTop

Edifice 3D Modeler is composed of four elements:

  • On the top, the menu gives access to all features and properties.
  • In the middle, the scene is the workspace to create 3D models and textures.
  • On the left, the tree details the current project elements.
  • On the bottom, the status bar displays application’s state information.
SceneTop
The scene is the workspace to create 3D models and textures.

 

Navigation

  • To move the point of view over the scene, press mouse right button and move mouse.
  • To elevate the point of view, press shift key, mouse right button and move mouse.
  • To rotate around the center of the view, press mouse middle button and move mouse.
  • To zoom in and out, scroll mouse wheel.

 

Action

  • To do an action, click with the mouse left button.

 

Selection

  • To enter selection mode, press space bar or click on select button in select menu.
  • To select an element, click on it with the mouse left button.
  • To select multiple elements, press shift key and click with mouse left button on each element you want to select.
  • To select multiple elements in a defined zone, press mouse left button and move mouse over the elements you want to select.

 

Grids

  • To modify the grid height position in space, press shift key and scroll mouse wheel.
  • To modify the grid size, press ctrl key and scroll mouse wheel.
  • To modify the grid divisions count, press ctrl key, shift key and scroll mouse wheel.
TreeTop
The tree details the current project and it’s elements.

Selection

  • To select an element in the scene, click with the mouse left button on it’s node.
  • To access element’s operations, click with the mouse right button on it’s node.

Model:

  • Create Group: Creates a group inside the current model

Groups:

  • Rename: Renames the selected group
  • Move Up: Place the selected group above the previous one.
  • Move Down: Place the selected group below the next one.
  • Duplicate: Creates and place a copy of the selected group.
  • Delete: Deletes the selected group.
  • Paste: Pastes the copied group

Elements:

  • Cut: Cuts the selected element.
  • Copy: Copies the selected element.
  • Paste: Pastes the selected element.
Status barTop
The status bar displays application’s state information:

  • Current menu.
  • Current feature.
  • Grid properties:
    • Size.
    • Subdivisions count.
    • Subdivision size.
    • Height.
  • Cursor position in space.
FileTop

The File menu lets you manage and visualize files:

  • Create, open, and save projects.
  • Visualize the construction of a model with the construction sequence.

New

  • New: Creates a new model.

Open

  • Open: Opens an existing model.

Import

  • Import: Import a model into the current model.

Save

  • Save: Saves the updates on the current model.
  • SaveAs: Saves the model in the defined path.

Export

  • Export: Saves the model in an external format.
  • Designs: Indicates if the supports are exported.
  • Productions: Indicates if the models are exported.
  • Entities: Indicates if the entities are exported.
  • Triangulate faces: Triangulate faces (Collada).

The construction sequence lets you see the model construction from the first to the last shape added. This sequence can be customized and it’s steps saved as pictures.

Sequence properties

  • Sequence step: Defines step display duration.
  • Sequence transition: Defines steps transition duration.
  • Save properties: Saves construction sequence properties.

Sequence read

  • Start: Navigates to the first step.
  • Previous step: Navigates to the previous step.
  • Play: Reads the construction sequence.
  • Pause: Pauses the construction sequence.
  • Stop: Stops the construction sequence.
  • Next step: Navigates to the next step.
  • End: Navigates to the last step.

Sequence Save

  • Save as images: Save construction steps as pictures.
ViewTop

The View menu presents display options:

  • Select the viewpoint and the perspective.
  • Ajust the grid size, the subdivisions count and location.
  • Define the visibility of the scene elements.

Views

  • Up: Up view.
  • Down: Down view.
  • Left: Left view.
  • Right: Right view.
  • Front: Front view.
  • Back: Back view.
  • Orbit: Orbit view.
  • Free: Free view.

Zooms

  • Zoom in: Increase the zoom in isometric views.
  • Zoom out: Decrease the zoom in isometric views.

Modes

  • Orthographic: Schematic-like view mode.
  • Perspective: Natural-like view mode.

Supports – Style

  • Wireframe: Display lines.
  • Textured: Display lines and faces.

Models – Style

  • Wireframe: Display lines.
  • Textured: Display lines and faces.

Supports – Guides

  • Show All Guides: Activates all support guides display.
  • Points: Indicates if points are displayed.
  • Lines: Indicates if lines are displayed.
  • Faces: Indicates if faces are displayed.
  • Models: Indicates if volumes are displayed.

Models – Guides

  • Show All Guides: Activates all model guides display.
  • Points: Indicates if points are displayed.
  • Lines: Indicates if lines are displayed.
  • Faces: Indicates if faces are displayed.
  • Models: Indicates if volumes are displayed.

Entities – Guides

  • Show All Guides: Activates all entities guides display.

Grids

  • Main: Displays the main grid.
  • Contextual: Displays the contextual grid.
  • Decimal grids: Indicates if grid subdivisions are a multiple of 10.
  • Snap to grids: Indicates if construction snaps into the grid intersections.
  • Size: the grid size in the space.
  • Subdivisions: the grid case subdivisions count.
  • Height: the grid height in space.
CreateTop

The Create Menu proposes tools to create supports and models:

– The Design mode lets you create supports.

– The Production mode lets you create models.

Point

  • Point: To create a point:
    • Click on the scene.

Line

  • Line: To create a multiline:
    • Click on the scene to place the first point.
    • Place points in the scene to obtain linked segments.
    • Push Enter key to end the line or close it by clicking on the first point.
  • Arc: To create an arc :
    • Click on the scene to place the starting point.
    • Place the ending point.
    • Click on the scene to define the height.

Face

  • Rectangle: To create a rectangle:
    • Click on the scene to place the top left corner.
    • Place the top right corner.
    • Place the bottom right corner.
  • Polygon: To create a polygon:
    • Click on the scene to place the first point.
    • Place points in the scene to the polygon sides.
    • Push Enter key to end the polygon or close it by clicking on the first point.
  • Square: To create a square:
    • Click on the space.
  • Disc: To create a disc:
    • Indicate in the menu the disc sides count.
    • Click on the scene to place the top left corner.
    • Place the top right corner.
    • Place the bottom right corner.
  • Ring: To create a ring:
    • Indicate in the menu the ring sides count and the inner diameter.
    • Click on the scene to place the top left corner.
    • Place the top right corner.
    • Place the bottom right corner.

Volumes

  • Box: To create a box:
    • Click on the scene to define the back left corner.
    • Place the back right corner.
    • Place the front right corner.
    • Click on the scene to define the height of the box.
  • Polyhedron: To create a polyhedron:
    • Place each point of the polyhedron base.
    • Click on the first point or push Enter key.
    • Click on the scene to define the height of the polyhedron.
  • Cube: To create a cube:
    • Click on the scene.
  • Cylinder: To create a cylinder:
    • Indicate in the menu the cylinder sides count.
    • Click on the scene to define the back left corner.
    • Place the back right corner.
    • Place the front right corner.
    • Click on the scene to define the height of the cylinder.
  • Tube: To create a tube:
    • Indicate in the menu the tube sides count and the inner diameter.
    • Click on the scene to define the back left corner.
    • Place the back right corner.
    • Place the front right corner.
    • Click on the scene to define the height of the tube.
  • Sphere: To create a sphere:
    • Indicate in the menu the vertical and horizontal sides count.
    • Click on the scene to define the back left corner.
    • Place the back right corner.
    • Place the front right corner.
    • Click on the scene to define the height of the sphere.

Modes

  • Support: The Support mode lets to create construction supports.
  • Model: The Model mode lets to create models.

Color

  • Paint: Click on a face to paint it with the defined color.
  • Drop: Click on a face to drop it’s color.
  • Default: Resets the defined color to it’s default value.
SelectTop

The Select menu presents selection and placement tools:

  • Define the possibility to select points, lines faces, and volumes.
  • Move, rotate, scale or adjust the position of the selected elements.

Select

  • Select: Place the application in selection mode.
  • Clear selection: Deselect all selected elements.

Supports

  • Select All Guides: Activates all support guides selection.
  • Points: Indicates if points are selectable.
  • Lines: Indicates if lines are selectable.
  • Faces: Indicates if faces are selectable.
  • Models: Indicates if volumes are selectable.

Models

  • Select All Guides: Activates all model guides selection.
  • Points: Indicates if points are selectable.
  • Lines: Indicates if lines are selectable.
  • Faces: Indicates if faces are selectable.
  • Models: Indicates if volumes are selectable.

Supports

  • Select All Guides: Activates all entities guides selection.
UpdateTop

The Update menu lists transformation and organization tools:

  • Move, rotate, and scale selected elements
  • Join or separate volumes
  • Hide selection and show hidden elements.
  • Create components from selection.

Edit

  • Undo: Cancels the last action.
  • Redo: Restores the last cancelled action.

Actions

  • Cut: Cuts the selection.
  • Copy: Copies the selection.
  • Paste: Pastes the selection.
  • Delete: Deletes the selection.

Hide

  • Hide: Hides the selected elements.
  • Show: Shows the hidden elements.

Join

  • Join: Fuse the selected volumes in a unique one.
  • Separate: Transforms the faces of the selected volume into distinct volumes.

Convert

  • To model: Transforms the selection in model.
  • To support: Transforms the selection in support.

Components

  • Create component: Creates a component from the selected volumes.
  • Uncompose: Transforms the selected component into editable volumes.
  • Reload selection: Reloads the selected component.
  • Reload instances: Reloads all the instances of the selected component.
  • Reload project: Reloads all the components of the current model.

Transforms

  • Move: Moves the selection according to:
    • The coordinates indicated in the menu.
    • The mouse moves in the scene.
  • Rotate: Rotates the selection according to:
    • The coordinates indicated in the menu.
    • The mouse moves in the scene.
  • Scale: Scales the selection according to:
    • The coordinates indicated in the menu.
    • The mouse moves in the scene.
  • Invert faces: Invert the selected faces.
TextureTop

The Texture menu lets you create and place textures on the models:
– Gather and visualize all your textures with the texture browser.
– Create textures with drawing tools.
– Generate a texture from a model with the photo feature.

Tool

  • Drop: Activates the drop mode:
    • Click on the face to see it’s texture selected in the menu.
  • Paint: Activates the paint mode:
    • Click on a face will apply the selected texture in the menu.
  • Create: Activates the Create mode:
    • Opens a tool to create textures.

Modes

  • Texture: Activates the Texture mode:
    • The texture is a picture used for model faces.
  • Brush: Activates the Brush mode:
    • The brush is a picture used as a pattern for textures.

Folders

  • Add: Adds a folder in the textures folders list.
  • Remove: Deletes a folder from the textures folders list.

File

  • New: Creates a new picture.
  • Open: Opens a picture.
  • Import: Imports a picture.
  • Photo: Creates a photo of the model.
  • Save: Saves the updates of the current picture.
  • SaveAs: Saves the picture in the defined path.

Layers

  • Diffuse: The diffuse map shows colors.
  • Normal: The normal map shows the reliefs.
  • Specular: The specular map shows the luminosity.

Tools

  • Pen:
  • Eraser:
  • Select:
  • Rectangle:
  • Disc:
  • Square: a square having grid case size
  • Drop: Gets the selected point color
  • Fill: Fills the selected zone the with the color selected in menu.
MapTop

The Map menu proposes tools to position the textures on the faces of the models:

  • Move, rotate, scale, or adjust coordinates of a texture on a face model.
  • The face perspective lets you position the texture on the face.
  • The texture perspective lets you position the face on the texture.

Modes

  • Drop: Activates the drop mode:
    • Click on a face to see it’s texture coordinates in the menu.
  • Paint: Activates the paint mode:
    • Click on a face to apply the texture coordinates defined in the menu.

Perspectives

  • Face: Updates the texture coordinates according to the face perspective.
  • Texture: Updates the texture coordinates according to the texture perspective.

Tools

  • Move: Moves the selected face texture according to the coordinates defined in the menu or in the scene.
  • Rotate: Rotates the selected face texture according to the coordinates defined in the menu or in the scene.
  • Scale: Scales the selected face texture according to the coordinates defined in the menu or in the scene.
  • Flip: Inverts the selected face texture according to the
AssembleTop

The Assemble menu lets to place in the current model other models as components:

  • Gather and visualize all your models with the components browser.
  • Place and replace components in the scene.

Modes

  • Place: Activates the place mode:
    • Select a model in the menu.
    • Click on the scene to place this model as a component.
  • Replace: Activates the replace mode:
    • Select the replacement model in the menu.
    • Click on the scene on the model to replace.
    • The replacement model appears at the place of the preceding model.
  • Replace All: Activates the replace all mode:
    • Select the replacement model in the menu.
    • Click on the scene on the model to replace.
    • The replacement model appears at each occurence of the preceding model.

Folders

  • Add: Adds a folder in the components folders list.
  • Remove: Deletes a folder from the components folders list.
AnimateTop

The Animate menu lets to animate models:

  • Select elements to animate.
  • Define elements positions through time.

Animations

  • Add: Adds an animation.
  • Delete: Deletes the selected animation.

Animation

  • Start: Navigates to the animation beginning.
  • Previous second: Navigates to the previous second.
  • Previous frame: Navigates to the previous frame.
  • Play: Reads the animation.
  • Pause: Pauses the animation.
  • Stop: Stops the animation.
  • Next frame: Navigates to next frame.
  • Next second: Navigates to the next second.
  • End: Navigates to the animation ending.
  • Select: Navigates to the selected second and frame.

Items

  • Add: Activates the Add mode:
    • Click on elements on the scene to add them in the animation.
  • Delete: Deletes the selected element from the animation.

Transformations

  • Add: Adds a transformation to the selected element.
  • Delete: Deletes the selected transformation.

Transformation

  • Move: position.
  • Rotate: orbit.
  • Scale: scale.
ScenarizeTop

The Scenarize menu lets to create animation movies:

  • Select elements to scenarize.
  • Define elements animations and camera positions through time.
  • Launch the scenario in a separate window.

Scenarios

  • Add: Adds a scenario.
  • Delete: Deletes the selected scenario.

Scenario

  • Start: Navigates to the scenario beginning.
  • Previous second: Navigates to the previous second.
  • Previous frame: Navigates to the previous frame.
  • Play: Reads the scenario.
  • Pause: Pauses the scenario.
  • Stop: Stops the scenario.
  • Next frame: Navigates to next frame.
  • Next second: Navigates to the next second.
  • End: Navigates to the scenario ending.
  • Select: Navigates to the selected second and frame.

Components

  • Items: Set elements transformations.
  • Camera: Set camera transformations.
  • Output: Set scenario properties.

Items

  • Add: Activates the Add mode:
    • Click on elements on the scene to add them in the scenario.
  • Delete: Deletes the selected element from the scenario.

Transformations

  • Add: Adds a transformation to the selected element.
  • Delete: Deletes the selected transformation.

Transformation

  • Move: position.
  • Rotate: orbit.
  • Scale: scale.

Camera

  • Add: Adds a transformation to the camera.
  • Delete: Deletes the selected transformation.

Camera transformation

  • Position:
  • Target:
InteractTop

The Interact menu lets to create interactive experiences:

  • Place triggers in the scene.
  • Connect triggers to animations.
  • Pass through triggers to activate animations.

Interactions

  • Add: Adds an interaction.
  • Delete: Deletes the selected interaction.

Triggers

  • Connect: Connects the selected trigger to the interaction.
  • Disconnect: Disconnects the selected trigger from the interaction.

Animations

  • Connect: Connects the selected animation to the interaction.
  • Disconnect: Disconnects the selected animation from the interaction.

Scenarios

  • Connect : Connects the selected scenario to the interaction.
  • Disconnect: Disconnects the selected scenario from the interaction.

Play

  • Play: Activate the interactions
HelpTop
The Help menu displays application information and links to Edifice 3D website.

Application information:

  • Version number
  • Edifice 3D website address
  • Contact information

Help:

  • Documentation: Displays Edifice 3D website.
  • Display contextual info: Displays information about the hovered button.